Preguntas
Temas

Reportes e impresión

Para abrir el diseñador de una plantilla:
  1. Haz una vista previa de impresión de la plantilla que quieres rediseñar.
  2. En la ventana de previsualización de impresión, pulsa en el menú: "Archivo" - "Personalizar Reportes". Se abrirá el diseñador de la plantilla.
herramienta personalizar reportes

En el menú "Ayuda" del programa encontrarás una guía de los conceptos básicos de uso del diseñador.
  1. Para cambiar el ancho del ticket de ventas, o cualquier otro impreso de ventas, entra en el Diseñador de Informes (en la ventana de vista previa de impresión, clic en "Archivo" - "Personalizar reportes"):
    personalizar reportes ticket
  2. Cambia el valor que aparece en la propiedad "Ancho de la página" del reporte:
    ancho pagina ticket
  3. La unidad de medida del reporte la puedes ver en la propiedad "Unidades de medida". Por defecto es Décimas de milímetro.
  4. Reubica y reajusta los campos para que queden ajustados al nuevo ancho del diseño y no queden fuera de los márgenes. Por ejemplo, si haces más estrecho el ancho, y dejaras los campos tal cual vienen por defecto, estos campos quedarían fuera de los márgenes. Para evitarlo tendrás que cambiar el tamaño de los campos y/o reubicarlos.
  5. Haz una Vista Previa antes de guardar para ver como quedan los cambios (Archivo - Vista Previa).
  6. Si todos los cambios que has realizado están correctos, ya puedes guardar el diseño. Para ello pulsa en "Archivo" - "Guardar".
En la fuente de datos de los impresos (albaranes, facturas, tickets, SAT y servicios) se cargarán los nº de serie que ha dado salida el documento a imprimir. Por ejemplo, si el SAT es el que ha registrado la salida del nº serie, se imprimirán en el impreso del SAT. Si la factura es la que ha registrado la salida del nº serie, se cargarán e imprimirán en la factura.


CONFIGURACIÓN PREVIA
Para que los nº de serie se carguen en la fuente de datos, primero deberás configurarlo en el programa:

  • Clic en menú Configuraciones
  • Opción Configuraciones generales del programa
  • Pestaña Productos
  • Marca las casillas y pulsa Aplicar

cargar nums serie reportes

 
PERSONALIZAR EL DISEÑO DEL IMPRESO

RECUERDA QUE, antes de guardar los cambios en una plantilla, es recomendable hacer una "Vista Previa" de los cambios (menú "Vista" - "Vista Previa"). Si todo está correcto, entonces puedes guardar los cambios realizados en la plantilla (menú "Archivo" - "Guardar")

Para añadir esos campos en el diseño, deberás personalizar el reporte y arrastrar esos campos en la zona donde quieras imprimirlos. Recuerda que los campos de la fuente de datos están en la ventana "Lista de campos" del diseñador.

Clic aquí para descargar un vídeo tutorial de ejemplo. 

En el vídeo se muestra un ejemplo de cómo personalizar la plantilla de factura para mostrar en el diseño los nº de serie del artículo. La operativa para editar otras plantillas, como la de ticket o SAT, es similar a los pasos mostrados en el vídeo.


Los campos relativos al nº serie registrado los encontrarás dentro de:
  • PLANTILLAS FACTURAS:  dentro del nodo: facturas - facturasdetalleFac - detalleFac_prodSeries
  • PLANTILLAS SAT: dentro del nodo: sat - escandalloSat - escandalloSat_prodSeries
  • PLANTILLAS TICKETS: dentro del nodo: tickets - ticketsdetalleTick - detalleTick_ProdSeries

Relación de campos:
  • numSerie: nº de serie
  • codigoV: corresponde al código del documento venta que ha registrado la salida
  • idProd: nº producto
  • referencia: referencia del producto
  • numLineaV: nº de línea de detalle de ventas
  • numSubLineaV: nº de línea de subdetalle de ventas
Para que el logotipo de tu Empresa sea mostrado de forma automática en los impresos (presupuestos, pedidos, facturas, SAT, servicios, contratos, etc.) simplemente deberás asociar la imagen del logo en la ficha de tu Empresa:

  1. Pulsa el menú "Empresa"
  2. Clic en botón "Empresas"
  3. Doble clic en la empresa para abrir su ficha
  4. En la pestaña "Logotipo" pulsa el botón "Cargar" para vincular la imagen de tu logo.
  5. Selecciona el tipo de imagen: .bmp, .png, . jpg.....
  6. Pulsa el botón "Aceptar" para guardar los datos de la ficha.

RECUERDA: Si trabajas, o vas a trabajar con los datos en red local, debes tener en cuenta los siguientes puntos cuando vincules ficheros e imágenes en el programa: Cómo vincular ficheros e imágenes en el software cuando trabajas con el programa en Red Local

Pestaña logotipo en la ficha empresa:

logotipo empresa esat
Los reportes del programa son exportables a distintos tipos de archivo: PDF, Excel, csv, texto plano, HTML, etc.

Puedes exportar el reporte desde la "ventana de previsualización del reporte".
  1. Clic en menú Archivo
  2. Clic en Exportar documento
  3. Pulsa en la opción que requieras

menu exportar informes


Recuerda que los reportes pueden ser rediseñados a través de la herramienta de "Personalizar reportes", incluida en el software, por lo que, si necesitas exportar ciertos reportes a un formato específico, puedes rediseñarlos para adecuarlos a un diseño más enfocada al tipo de archivo al cual quieres exportarlo.
Si. Si te has equivocado diseñando una plantilla, y ahora contiene errores y no la puedes abrir o imprimir, o bien quieres volver a usar el diseño que venía por defecto en el programa, puedes restaurarla fácilmente desde la opción "Reestablecer los reportes predeterminados".

Esta acción implicará que se sobreescriba la plantilla seleccionada. Es decir, perderás cualquier cambio que hubieras realizado sobre ella.

  1. Clic en el menú Configuraciones - opción Reestablecer los reportes predeterminados
  2. Aparecerá una pantalla con todos los reportes incluidos en el programa. Marca la plantilla que quieras restaurar.
  3. Pulsa el botón Aceptar para proceder con la restauración

restablecer plantillas reportes software esat